Back to overview
Degraded

Some Ancillary Services Down

Oct 30 at 01:33pm GMT
Affected services
IT Helpdesk
Writer's Portal

Resolved
Oct 30 at 01:49pm GMT

✅ Following a short investigation, degraded service is now fixed for ALL users in ALL regions.

Created
Oct 30 at 01:33pm GMT

ℹ️ Some ancillary services including Writer's Portal and IT Helpdesk are reported down. This affects SOME users in SOME regions. IT are working on a fix.